Archive for ‘September, 2014’

Not sure why this is such a mystery, but it took the better part of the day to troubleshoot. The main issue with forum posts is that people have the right idea/intention, but the forum software mistreats the actual command line/short code. Spacing really really (did I say really) matters. I’m assuming that you’re using the default player definition that comes with the plugin. If you need to change it then make the appropriate change to this code as well. The code to get both RTMP and HLS working depends on defining both of those sources. In my case the source is my Wowza Server and I have two URI’s:

1) For HLS I use http://wowza.server.ip.address:1935/live/many/playlist.m3u8

2) For RTMP I use rtmp://wowza.server.ip.address:1935/live/many

Obviously as you can see my Wowza application is “live” and the stream instance name is “many”. So for this to work transparently in HTML (HLS) and Flash (RTMP) environments you need the following code inserted into a post or page in wordpress (make sure you do it in Text view, NOT Visual view):

[player sources="{ file: 'http://wowza.server.ip.address:1935/live/many/playlist.m3u8'},{ file: 'rtmp://wowza.server.ip.address:1935/live/many'}"]

NOTE: The above code intentionally starts with [player….Please replace it with jwplayer instead. I can’t seem to put the code in properly without the plugin — installed on this site — interpreting the code as shortcode.

Also, I can not be more clear…..SPACES DO MATTER HERE…..SO PAY ATTENTION!!!